前端项目搭建出现问题,求解

提问 已结 3 999
汤姆和杰瑞
悬赏:20积分
版本:renren-security 2.0.0 浏览器:Chrom
从朋友那里知道这个东西,便想试着搭建一下 结果在前端环境这个卡住了,具体问题是:点击【菜单管理】报错,后端正常,且数据库正常 前端报错信息: [pre] [Vue warn]: Error in callback for watcher "data": "Error: if there's nested data, rowKey is required."....... [/pre] 调查一番后,之前也有帖子说是 element-ui 组件问题: a(https://www.renren.io/detail/11377)[https://www.renren.io/detail/11377] 奈何前端水平不行,求各位帮忙看看,如何解决 这是我查看我本地的 element-ui 的版本信息 [pre] `-- UNMET DEPENDENCY element-ui@2.4.7 npm ERR! missing: element-ui@2.4.7, required by renren-security@2.0.0 [/pre]
回帖
  • 我们开发环境,都是npm install,就能下载完依赖,不会出问题
    0
  • 汤姆和杰瑞
    2019-04-10
    @Mark 感谢回复,我是用 cnpm 进行安装 安装完成后其他的东西都正常,唯独【菜单管理】无法显示,是 element-ui 表单树形结构的问题 到现在,我还是没什么解决思路face[泪]
    0
  • 汤姆和杰瑞
    2019-04-10
    结贴,挂个 VPN,使用 npm install 就好了 为什么使用 cnpm install 会不对呢face[晕]
    0
本帖已结贴