npm run build 打包报错

提问 未结 5 572
古末
古末 2019-12-04
悬赏:20积分
版本:renren-fast 开发环境:
刚开始一直是在本地运行,也没做过打包操作,但是,当项目接口跑完都ok后就打包想放线上跑一下,谁知道就开始报错.... img[//cdn.renren.io/af04f201912040913183414.png] 好吧,然后我百度说是gulp和node版本冲突,要不然gulp升级要不然node降级,然后我就把gulp升级到了4.0.2版,然后又报语法错误.... 然后我就去改语法 img[//cdn.renren.io/e4285201912040916324262.png] 然后打包,又报错........ img[//cdn.renren.io/3cda5201912040919012318.png] 我查了官方的gulp文档,我也没找到这个解决办法,所以恳请救急,产品一直在催着呢face[泪] face[泪] face[泪] face[泪] face[泪]
回帖
  • 我们本地执行npm run build没有报错,下面是我们的版本信息 [pre] D:\renrenio\renren-fast-vue>npm -v 6.9.0 D:\renrenio\renren-fast-vue>node -v v10.16.0 D:\renrenio\renren-fast-vue>gulp -v [10:07:13] CLI version 3.9.1 [10:07:13] Local version 3.9.1 [/pre]
    0 回复
  • 古末
    古末 (楼主)
    2019-12-04
    但是现在都是node最新版啊,好吧我降低版本,能发我一个node10.16.0的包吗?或是给我一个下载地址也行
    0 回复
  • 词不达意
    2019-12-10
    node版本和gulp版本冲突,我是降低node版本v.11.15.0
    0 回复
  • Tddxx
    2019-12-25
    楼主解决了吗
    0 回复
  • ynwshy
    2020-01-15
    gulp 3 和 gulp 4 的语法是不一样了 但是你还是没改对! 我的node 也是12.13.0了 把gulp相关依赖改成4版本的 img[//cdn.renren.io/26427202001151632585883.png]
    1 回复