前端启动报错

提问 已结 1 68
雨晨的清风
悬赏:20积分
版本:renren-security 2.5.0 开发环境:chrome
PS D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin> npm install npm WARN eslint-config-standard@12.0.0 requires a peer of eslint@>=5.0.0 but none is installed. You must install peer dependencies yourself. npm WARN eslint-plugin-standard@4.0.0 requires a peer of eslint@>=5.0.0 but none is installed. You must install peer dependencies yourself. npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents): npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"}) up to date in 19.444s PS D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin> npm run serve > security-enterprise-tenant-admin@2.5.0 serve D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin > vue-cli-service serve INFO Starting development server... 54% building 371/390 modules 19 active ...n\node_modules\normalize-wheel\index.jsBrowserslist: caniuse-lite is outdated. Please run next command `npm update` 98% after emitting CopyPlugin ERROR Failed to compile with 12 errors 9:49:05 error in ./src/assets/scss/aui.scss Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./src/assets/scss/aui.scss 4:14-231 14:3-18:5 15:22-239 @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/components/ren-region-tree/src/ren-region-tree.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/components/ren-region-tree/src/ren-region-tree.vue?vue&type=style&index=0&lang=scss& 4:14-481 14:3-18:5 15:22-489 @ ./src/components/ren-region-tree/src/ren-region-tree.vue?vue&type=style&index=0&lang=scss& @ ./src/components/ren-region-tree/src/ren-region-tree.vue @ ./src/components/ren-region-tree/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/tenant/tenant-add-or-update.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/tenant/tenant-add-or-update.vue?vue&type=style&index=0&lang=scss& 4:14-486 14:3-18:5 15:22-494 @ ./src/views/modules/tenant/tenant-add-or-update.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/tenant/tenant-add-or-update.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/sys/menu-add-or-update.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/sys/menu-add-or-update.vue?vue&type=style&index=0&lang=scss& 4:14-484 14:3-18:5 15:22-492 @ ./src/views/modules/sys/menu-add-or-update.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/sys/menu-add-or-update.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/sys/region-add-or-update.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/sys/region-add-or-update.vue?vue&type=style&index=0&lang=scss& 4:14-486 14:3-18:5 15:22-494 @ ./src/views/modules/sys/region-add-or-update.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/sys/region-add-or-update.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/sys/user-add-or-update.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/sys/user-add-or-update.vue?vue&type=style&index=0&lang=scss& 4:14-484 14:3-18:5 15:22-492 @ ./src/views/modules/sys/user-add-or-update.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/sys/user-add-or-update.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/sys/dept-add-or-update.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/sys/dept-add-or-update.vue?vue&type=style&index=0&lang=scss& 4:14-484 14:3-18:5 15:22-492 @ ./src/views/modules/sys/dept-add-or-update.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/sys/dept-add-or-update.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/sys/log-error.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/sys/log-error.vue?vue&type=style&index=0&lang=scss& 4:14-475 14:3-18:5 15:22-483 @ ./src/views/modules/sys/log-error.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/sys/log-error.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/gxbg/detailstwo-add-or-update copy.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/gxbg/detailstwo-add-or-update copy.vue?vue&type=style&index=0&lang=scss& 4:14-495 14:3-18:5 15:22-503 @ ./src/views/modules/gxbg/detailstwo-add-or-update copy.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/gxbg/detailstwo-add-or-update copy.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/gxbg/detailstwo-add-or-update.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/gxbg/detailstwo-add-or-update.vue?vue&type=style&index=0&lang=scss& 4:14-490 14:3-18:5 15:22-498 @ ./src/views/modules/gxbg/detailstwo-add-or-update.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/gxbg/detailstwo-add-or-update.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/modules/gxbg/detailstype-add-or-update.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/modules/gxbg/detailstype-add-or-update.vue?vue&type=style&index=0&lang=scss& 4:14-491 14:3-18:5 15:22-499 @ ./src/views/modules/gxbg/detailstype-add-or-update.vue?vue&type=style&index=0&lang=scss& @ ./src/views/modules/gxbg/detailstype-add-or-update.vue @ ./src/views/modules lazy ^\.\/.*$ namespace object @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js error in ./src/views/main-navbar-switch-tenant.vue?vue&type=style&index=0&lang=scss& Module build failed (from ./node_modules/sass-loader/lib/loader.js): Error: Missing binding D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\vendor\win32-x64-72\binding.node Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 12.x Found bindings for the following environments: - Windows 64-bit with Node.js 10.x This usually happens because your environment has changed since running `npm install`. Run `npm rebuild node-sass` to download the binding for your current environment. at module.exports (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\binding.js:15:13) at Object.<anonymous> (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\node-sass\lib\index.js:14:35) at Module._compile (internal/modules/cjs/loader.js:1133:30) at Object.Module._extensions..js (internal/modules/cjs/loader.js:1153:10) at Module.load (internal/modules/cjs/loader.js:977:32) at Function.Module._load (internal/modules/cjs/loader.js:877:14) at Module.require (internal/modules/cjs/loader.js:1019:19) at require (internal/modules/cjs/helpers.js:77:18) at Object.sassLoader (D:\workspace-idea-work\security-enterprise-tenant-2.5.0\security-enterprise-tenant-admin\node_modules\sass-loader\lib\loader.js:46:72) @ ./node_modules/vue-style-loader??ref--8-oneOf-1-0!./node_modules/css-loader??ref--8-oneOf-1-1!./node_modules/vue-loader/lib/loaders/stylePostLoader.js!./node_modules/postcss-loader/src??ref--8-oneOf-1-2!./node_modules/sass-loader/lib/loader.js??ref--8-oneOf-1-3!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/main-navbar-switch-tenant.vue?vue&type=style&index=0&lang=scss& 4:14-455 14:3-18:5 15:22-463 @ ./src/views/main-navbar-switch-tenant.vue?vue&type=style&index=0&lang=scss& @ ./src/views/main-navbar-switch-tenant.vue @ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/main-navbar.vue?vue&type=script&lang=js& @ ./src/views/main-navbar.vue?vue&type=script&lang=js& @ ./src/views/main-navbar.vue @ ./node_modules/cache-loader/dist/cjs.js??ref--12-0!./node_modules/babel-loader/lib!./node_modules/cache-loader/dist/cjs.js??ref--0-0!./node_modules/vue-loader/lib??vue-loader-options!./src/views/main.vue?vue&type=script&lang=js& @ ./src/views/main.vue?vue&type=script&lang=js& @ ./src/views/main.vue @ ./src/router/index.js @ ./src/main.js @ multi (webpack)-dev-server/client?http://192.168.2.106:8001/sockjs-node (webpack)/hot/dev-server.js ./src/main.js
回帖
本帖已结贴