更新 renren-security4.0版本后,Oauth2Filter.java报错

提问 3 1024
阿布
阿布 VIP3 2023-08-11
版本:renren-security 4.0 开发环境:
前两天更新renren-security4.0版本后,在pom.xml加入自己的maven模块编译时报错Oauth2Filter.java 报:无法访问javax.servlet.Filter,SmsController.java和LoginController.java其它有些类报:找不到符号。请教各位,我这里的报错是什么原因造成? img[//cdn.renren.io/789ad202308111050468608.png]
回帖
  • 阿布
    阿布 VIP3 (楼主)
    2023-08-11
    4.0版本之前,都是这样更新项目的没有任何问题。 当移除renren-admin中pom.xml的自己开发的模块信息后,编译正常。只要加入自己的模块,编译错误。
    0
  • 这次是不向下兼容了,springboot3.x没办法向下兼容,且必须使用java17,javax的包也都移除了
    0
  • 阿布
    阿布 VIP3 (楼主)
    2023-08-11
    好的,谢谢
    0
本帖已结贴